Segmentation Faults in PHP5 bei Debian GNU/Linux 5.0 (Lenny)

Nachdem ich ein paar Webseiten eingerichtet habe flogen mir regelmässige Segmentation Faults um die Ohren:

kernel: [717604.089640] php-cgi[26348]: segfault at 7ff99a76bac0 ip 7ff99a76bac0
 sp 7fffaa1e0088 error 4 in libtasn1.so.3.0.15[7ff99d73f000+f000]
kernel: [717604.119036] php-cgi[26347]: segfault at 7ff99a76bac0 ip 7ff99a76bac0
 sp 7fffaa1e0088 error 4 in libtasn1.so.3.0.15[7ff99d73f000+f000]
kernel: [717604.123062] php-cgi[26349]: segfault at 7fe00b9dbac0 ip 7fe00b9dbac0
 sp 7fff1b452298 error 4 in libtasn1.so.3.0.15[7fe00e9af000+f000]

Nach etwas Suche fand ich Debian Bug #411982. Die Lösung ist ziemlich simpel, man muss das php5-Modul pgsql vor curl laden, z.B. per mv pgsql.ini 0pgsql.ini.

Flattr this!

Leave a Reply